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Chapter 1

Introduction

This manual contains instructions for the applications Submit,
Tarski’s World, Fitch, and Boole. These four applications are de-
signed to be used with the textbook Language, Proof and Logic,
and are contained on the CD-ROM that comes packaged with the
text. This manual simply tells you how to use the software, not
about the logical concepts behind the software. For that you need
to read, and complete exercises from, the text.

This manual assumes that you know the basics about using your
computer, things like plugging it in, starting applications, opening
and saving files, using menus, basic editing, muttering quietly when
things go wrong, and quitting. If you don’t, you should ask a friend,
consultant, your instructor or a younger sibling to get you started.
We will focus on what is special about the packaged applications.

Tarski’s World, Fitch, and Boole are used for completing exer-
cises interspersed through the text. Submit, by contrast, is used for
submitting the exercise files thus completed to an Internet-based
grading service called the Grade Grinder. The Grade Grinder re-
ceives the files sent by Submit, and then returns an assessment of
those files to you (and to your instructor, if you so choose). To sub-
mit exercises, you will need the unique Book ID that comes with
the package and your computer must be able to access the Inter-
net. (If you can browse the World Wide Web from your computer,
then you will also be able to submit files.)

This manual should be used as a reference when you are work-
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ing through the textbook. When you start using one of the ap-
plications, you should read through enough of the corresponding
chapter of the manual to get started. Then, if you have trouble
with some feature, or can’t figure out how to do something, you
should try to look it up in the manual.

1.1 System requirements

The CD-ROM contains versions of the applications for Windows,
Macintosh, and Linux.

For specific system requirements, consult the ReadMe file on
the CD-ROM or the LPL web site.

Administrative privileges are needed to install the software.
(Under some circumstances, the applications may be run without
installation, but this is strongly discouraged.)

Internet access is required only when using Submit.

If you are working on a public computer, you should be careful
not to leave your homework files on the computer once you are
finished, since the files may be erased or copied by another user.

1.2 LPL Web site

If you encounter problems with the software, you should consult
the help pages on the LPL web site. The address of this web site
is:

http://1pl.stanford.edu

The web site also contains the latest information about the soft-
ware, and downloadable updates for registered users.

If you discover a bug in the software, first consult the web site
above for any information that we might have about the issue. If
this doesn’t address the problem, please send email to

LPLbugs@csli.stanford.edu
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Chapter 2
Using Submit

Submit is a computer program that allows you to submit your
homework exercises over the Internet to the Grade Grinder, a grad-
ing server that checks your homework and returns reports to you
and, if you ask, your instructor. In this chapter we describe how
to use Submit.

2.1 Getting started

The computer you use to submit homework to the Grade Grinder
must be connected to the Internet. Submit uses the same form
of communication used by web browsers, so if you can access the
Internet with your web browser, you should be able to submit files
to the Grade Grinder.

To submit files to the Grade Grinder, you need to have all of
the following ahead of time:

1. The solution files you want to submit. You might want
to collect together all the files you want to submit in a single
folder. Remember that the files must be named exactly the
way you are asked to name them in the book. Submit will
only send files whose names begin with World, Sentences,
Proof, or Table, and that are of the appropriate type (Tarski’s
World, Fitch, or Boole files). If you try to submit a file with
an incorrect name, it will give you a chance to correct the
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name. If you try to submit a file with an incorrect exercise
number (e.g., World 1.1 rather than World 10.1), then Submit
will send it but the Grade Grinder will tell you that it doesn’t
know how to grade it or grade it as the wrong exercise. Be
careful when naming your solution files!

2. Your Book ID number. This is a unique ID number that
is included in the LPL package. It is of the form L11-1234567,
that is, a letter, followed by two digits, a dash, then seven
more digits. Do not let anyone else use your ID number,
since the number is how the Grade Grinder associates your
homework exercises with you.

3. Your name and full email address. The name you enter
should be sufficient for your instructor to identify you. It
is important that you enter your full email address, for ex-
ample claire@cs.nevada-state.edu, not just claire or claire@cs
or claire@cs.nevada-state—since the Grade Grinder will need
the full address to send its response back to you. You must
use the same email address throughout the course, so make
sure you choose the right one and enter it correctly. If you
don’t have an email address, or don’t know your full Inter-
net email address, contact one of the computer folks at your
school.

4. Your instructor’s name and full email address. If you
want your results to be sent to an instructor as well as to you,
you will need his or her name and full email address. The
instructor’s email address must match one of the instructors
in the Grade Grinder’s database, so make sure you find out
what it is. If you do not want results sent to an instructor,
you won’t need this information.

Launching Submit

To launch Submit double-click on the application icon, which has
a blue background and shows the yellow corner of a cube.! After a
moment, Submit’s main window will appear on your screen. You’ll
know it by the twirling cube.

1If you installed Submit on a Windows machine, you can also launch
the program from the Start menu by choosing Programs/LPL Soft-
ware/Submit.
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Your goal is simply to fill in the various parts of this window
by typing in the information requested and specifying the list of
files to be submitted. Once that is done, you will simply press the
Submit Files button in the lower right of the window.

Start by filling in the information requested (Book ID, your
name, etc.). Read about this information above if you haven’t
already. Remember to use your full email address and to spell
it correctly. Once you have submitted files, your Book ID will
be associated with the email address you type in, so that no one
can use your Book ID to submit bogus homework in your name.
In later submissions, you will have to use the exact same email
address with your Book ID, so if you have more than one email
address, remember which one you used.

2.2 Choosing files to submit

There are several ways to choose the files you want to submit. The
most common is to click on the button Choose Files to Submit
in the lower left corner of the main Submit window. This will open
another window showing two file lists. The list on the left shows
all the files in the current folder (directory). The list on the right
will be built by you as you choose files to submit. The goal is to
find the names of your solution files on the lefthand list and move
them to the righthand list.

To find your solution files, you will have to navigate around
the folder structure of your computer in the lefthand list. To move
to “higher” folders, those containing the folder whose contents is
currently shown in the list, click on the folder name that appears
above the list. A menu will pop up and show all the folders (and
volume) that contain this folder. Choose the folder whose contents
you want to view. To move to “lower” folders, those contained in-
side the folder whose contents you are viewing, choose those folder
names from the list and click Open, or simply double-click on
the folder names. Using these two techniques, you will be able to
find any file located on your computer’s hard disk or on any disk
inserted into one of the computer’s drives.

Once you have found the file(s) you want to submit, select the
file name in the lefthand list and click the Add>>> button to add
the name to the righthand list. Keep doing this until the righthand
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list contains all the files you want to submit. If any of the files are
of the wrong type or have names of the wrong form, Submit will let
you know before putting them on the list. It will give you a chance
to correct the names of files that are of the right type, but not
named correctly. (This does not change the names of the files on
your computer, only the name sent to the Grade Grinder.) When
you are finished choosing files, click the Done button under the
righthand file list.

Another way to specify files to submit is by choosing Choose
File to Submit. .. from the File menu while you are at the main
Submit window. This gives you the standard file open dialog box.
If you choose a file of an appropriate type (e.g., a Fitch file), it will
be added directly to the list of files to submit. This takes longer if
you have more than one file to submit.

The fastest way to specify the files to submit is to drag the files
(or a folder containing them) to the Submit application icon. This
will launch Submit (if it is not already running) and put the file
names directly onto the list of files to submit.

Submitting the files

Once you have entered all the information on the main Submit
window and have constructed the list of files to submit, click the
Submit Files button under the list of files. Submit will ask you
to confirm that you want to submit the files on your list, and
whether you want to send the results just to you or also to your
instructor. When you are submitting finished homework exercises,
you should select Instructor Too, but if you just want to check
to see if you’ve done the problems right, select Just Me. One of
these boxes must be chosen before you click the click the Proceed
button, which sends your submission.

If you wish, you can use the Add Text Message button to
send a text message with your submission. This message will ap-
pear in the text of the grade report. It is useful for complaining to
your instructor about how long you spent on the exercises.

After a moment, you will get a notice back from the Grade
Grinder telling you which files it received and which of them it
knows how to grade. (If you misnumbered a solution, it won’t
know how to grade it.) You can save this notice as a receipt to
prove that the files got to the Grade Grinder.
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What Submit sends

When you submit files to the Grade Grinder, Submit sends a copy
of the files. The original files are still on the disk where you orig-
inally saved them. If you saved them on a public computer, it is
best not to leave them lying around. You should put them on a
floppy disk that you can take with you, and delete any copies from
the public computer’s hard disk.

2.3 How you know your files were re-
ceived

If you receive the notice back from the Grade Grinder described
above, then you know your files were received. If you receive an
error message, or if nothing at all happens when you try to submit
your files, then the Grade Grinder has not received them. If your
submission does not get through, it is probably a problem with
your Internet connection. You should try submitting them again,
perhaps from another computer. There are presently two Grade
Grinder servers (one in California and one in Illinois), and if Submit
cannot find one, it looks for the other. If it fails both times it is
probably because your computer or local network cannot access
the Internet. If you are certain that you are connected to the
Internet, you may be able to solve this problem by modifying the
proxy server settings in the preferences dialog (see section 2.4.1.)

A second confirmation that your submission was received is
the email message that the Grade Grinder will send you with the
results of its grading. This will arrive a while after you make the
submission, depending on how large the submission was, how many
other submissions the Grade Grinder is checking, and how long it
takes email to reach you. Generally, you will receive the email
message within minutes of submitting your files.

You can check on a submission by clicking on the GG Status
button at the bottom of the Submit window. If the Grade Grinder
was unable to grade your submission, it will tell you which of your
submissions have been delayed and for what reasons.
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Figure 2.2: Submit Preferences Window

2.4 Preferences and User Data

The information that you enter into the main Submit window,
other than the files to submit, is known as the user data. If you
would like to avoid typing your name, email address, etc., each time
you submit files, you can save all of this information except the
Book ID. You do this by choosing Save or Save As... from the
File menu. This will let you save a file containing this information.

If you save this file with the default name, Submit User Data,
and put it in the folder suggested by Submit this information
will automatically be entered into the appropriate fields when you
launch the program. Alternatively, the user data file can be lo-
cated elsewhere and opened from within Submit using the Load
Preference File... command from the File menu. Or, on the
Macintosh, you can launch Submit by double-clicking on the user
data file, and this too will enter the data into the appropriate fields.
In these latter two cases, the name of the user data file does not
have to be Submit User Data.

The Submit User Data file also contains preference settings which
may be changed from the Preferences window, which is obtained by
using the Preferences command from the Application menu (Mac-
intosh) or File menu (Windows). If you use this command, a win-
dow similar to that shown in figure 2.2 will appear.

You can change a number of aspects of the way in which Submit
behaves using the controls in this window.
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2.4.1 Proxy Server Settings

In some cases, you may not be able to connect directly to the
Internet to make web connections, usually because your machine
is located behind a firewall. In such a situation, there will be a
computer that you are allowed to access, and this machine makes
connections to the Internet on your behalf, returning the results to
your machine. A computer configured in this way is called a “proxy
server”. If you need to use a proxy server, you should check the
box marked Use Proxy Server and enter the name of the server, and
the port to connect to, in the text fields below. You will be able
to obtain the correct information from the corresponding proxy
settings in your web browser, or from a local system administrator.

The default setting is not to use a proxy server, and unless
it is necessary to use one, these settings should normally be left
unchanged.

2.4.2 Preferred Host Settings

The Grade Grinder is implemented by multiple computers called
grade servers. There are currently two grade servers, one located
at Stanford University and the other at the University of Chicago
(but this may change.) By default, when you make a submission,
Submit will determine which server is least busy, and send your
submission to that server. This is called “load balancing”. How-
ever, if you wish you can ask Submit to prefer one of the servers
over the other. To do this, check the radio button marked “Use
Preferred Server”, and then the radio button that corresponds to
your choice of server.

The default setting is to use load balancing, and we do not
recommend changing from the default, since you run the risk of
unnecessarily delaying your own submissions. The only situation
in which selecting a preferred server might be beneficial is if prob-
lems with one of the Grade Grinder servers, causes it to accept
submissions but be delayed in grading them. If this happens, then
preferring to send submissions to the other server would be appro-
priate.

It is important to know that selecting a preferred server does
not guarantee that your submissions will always go to that server.
It is a preference, not a guarantee. Submit will try to send your
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submission to your preferred server first, but if that server is un-
available then the other server(s) will be used instead.

Unlike the other settings, information about your host pref-
erences are stored in the file Submit Host Data. These may be
changed on your behalf, if for example your preferred grade server
is taken off line, or if other grade servers are added.

2.4.3 Timeout settings

Submit waits a period of time called the “timeout” when connect-
ing to a grade server. If the server does not respond within this
time, the next server is tried, until either one accepts the submis-
sion or all have been unsuccessfully tried, in which case you will be
notified of the problem. You can modify the length of the timeout
value using the timeout choice menu. If you are routinely having
difficulty connecting to a grade server within the timeout period,
perhaps because you are connecting over a slow dialup line, or
sending very large submissions, then you may wish to change the
setting to Patient or Very Patient in order to instruct Submit to
wait longer for a response. You might like to experiment with the
(Very) Impatient settings if you think that you will routinely get
very fast responses from the server (perhaps because your connec-
tion is very fast due to being on the Internet backbone.)

2.4.4 Personality

The Grade Grinder generates congratulatory messages in the grade
report when you get an exercise completely correct. By default,
the “classic” behavior, these are randomly selected. You can con-
trol the exclamations that are generated by using the Personality
setting, or switching all exclamations off using the setting “None”
if you prefer.
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Chapter 3

Using Tarski’s World

Tarski’s World lets you represent simple, three-dimensional worlds
inhabited by geometric blocks of various kinds and sizes, and test
first-order sentences to see whether they are true or false in those
worlds. We begin with instructions on how to start and stop
Tarski’s World, and explain the basic layout of the screen.

3.1 Getting started

The Tarski’s World application is contained inside the folder called
Tarski's World Folder. Also in this folder is a folder called TW
Exercise Files, in which you will find the Tarski’s World exercise
files referred to in the book.

When Tarski’s World is running you will see a large window di-
vided into two sections. The upper world panel contains a checker-
board on which blocks are placed, called a world, and a tool bar
for manipulating the content of this world. Immediately above the
world is a tab which contains the name of the world. Initially this
is Untitled World.

The sentence panel is the white panel at the bottom of the
window. At first it contains only the numeral “1” inside. This is
where sentences are entered and evaluated to see whether they are
true or false in the world represented in the world window. Feel
free to type something in the sentence window, say, “I'd rather be
in Philadelphia.” Immediately above the sentences is a tab which
contains the name of the collection of sentences. Initially this is
Untitled Sentences.

15
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The sentence toolbar appears above the sentence panel. We
generally use these tools to enter sentences of first-order logic. Feel
free to play around by clicking on the buttons in the sentence
toolbar.

3.1.1 Opening saved files

Both worlds and sentence lists can be saved as files on your disk.
Indeed, many prepackaged world and sentence files come with
Tarski’s World. To open a saved file, you use the Open... com-
mand on the File menu.

To open a file, pull down the File menu and choose Open....
A file dialog will appear which allows you to navigate to the file that
you wish to open. You will have to navigate to the right folder to
find the prepackaged files, which are in TW Exercise Files. Find this
folder, select it, and then click Open, or simply double-click on the
name. Feel free to open one of the files you see, say, Ackermann’s
World, but if you make any changes to the world, don’t save them.

When you open a file, a new tab will be created above the new
sentence or world panel.! This tab will contain the name of the file
that you opened. To return to viewing any other world or sentence
file, just click on its tab, and it will reappear.

3.1.2 Starting new files

If you want to start a new world or sentence file, choose New
from the File menu. You may then specify whether you want a
new world or new sentence file from the menu which appears. The
New World and New Sentences commands create a new empty
world or sentence panel as appropriate. These are created as new
tabs within the collection of worlds or sentences.

The command New Random World on the New menu cre-
ates a new world, and populates it with randomly chosen blocks.

The New Window item on the New menu creates a new
window identical to the initial main window.

You may have noticed that there is another New command
on the File menu. depending on which panel is active, this reads

1There is one exception to this rule, and that is when the current tab is
one of the “Untitled” tabs that has not been changed. In this case the old tab
will be replaced by the new one.
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New Sentences or New World, and is equivalent to the corre-
sponding item on the New submenu. This item also has a shortcut.

3.1.3 Saving a file

If you want to save a file, use the Save submenu from the File
menu. There are items here which allow you to save the current
world, Save World or Save World As..., the current sentences,
or all worlds and sentences in all tabs.

If the file has never been saved before, a dialog box will appear
giving you the option of naming the file you are about to create.
If you were to hit the return key, or click the Save button, the file
would be saved with the default name. You should type in some
other name before hitting the return key or clicking Save. You
should also make sure you are saving the file where you want it.
Check the directory name at the top of the save dialog box. If
you’re not in the folder where you want to save the file, navigate
to the right one by clicking on this name.

You may have noticed that there is another save command on
the File menu. depending on which panel is active, this reads Save
Sentences or Save World, and is equivalent to the corresponding
item on the Save menu. This item also has a shortcut.

Once a file has been saved, the name of the file appears in the
corresponding tab. If you are working on a named file, the Save
and Save As... commands behave differently. The first will save
a new version of the file under the same name, and the old version
will be gone. The second gives you a chance to create a new file,
with a new name, and keeps the old file, with its name. For this
reason, Save As... is the safer of the two options.

You can also access the save commands by control-clicking
(Macintosh) or right-clicking (Windows) on the corresponding tab.

All files created by Tarski’s World can be read by either the
Macintosh or Windows version of the application.

3.1.4 Closing Tabs

When you are done with a world or sentence file, you can close it
using the Close commands on the File menu. As usual, there is
a command which closes the active tab whether it is a world or
sentence, and a submenu which allows you to close the tab of your
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choice. The close commands can also be accessed from the tab’s
menu.

3.1.5 Reverting a File

If you want to reload a tab from its corresponding file, you can do
so using the Revert submenu on the File menu. You will be asked
first whether you want to save the changes that you have made to
the file (to a different file), and then the content of the current tab
will be replaced from the file. This command an also be accessed
from the tab’s menu.

3.1.6 Printing

To print your sentences or world, choose the appropriate Print
command from the File menu, or from the tab’s popup menu. If
your computer is not connected to a printer, this probably won’t
work.

3.1.7 Quitting (Exiting) Tarski’s World

Eventually you will want to leave Tarski’s World. To do this,
choose Quit from the application menu (Exit from the File menu
on Windows). If you've made any unsaved changes to the files,
Tarski’s World will give you a chance to save them.

3.2 The World Panel

3.2.1 Adding blocks

To put a block on the grid, simply click the New button on the
tool bar. Try this out. The size and shape of block that is created
can be controlled by setting a preference (see section 3.6). A small
cube is created by default.

3.2.2 Selecting blocks

A block can be selected by clicking on it. The block will change
color to indicate its selection. To unselect a block, click elsewhere
in the world window.



UsiNG TARSKI'S WORLD / 19

To select more than one block, hold down the shift key while
clicking on the blocks. If many blocks are selected, and you want
to deselect one of them, click on it while holding down the shift
key.

3.2.3 Moving blocks

To move a block, position the cursor over the block and drag it to
the desired position. (That is, move the mouse’s arrow over the
block and then, with the button depressed, move the mouse until
the block is where you want it.) If multiple blocks are selected,
they will all move.

If you move a block (or blocks) too close to the edge it will fall
off.

3.2.4 Sizing and shaping blocks

To change a block’s shape, select it and click on one of the shape
buttons on the toolbar. These display a triangle, square and pen-
tagon and change the shape to tetrahedron, cube and dodecahe-
dron, respectively. If multiple blocks are selected all will changed
to the new shape.

Similarly, to change a block’s size, select it and click on one
of the size buttons on the toolbar. These display circles of small,
medium and large sizes. If multiple blocks are selected all will
changed to the new size.

3.2.5 Naming blocks

When a block is selected, the name checkboxes on the toolbar
are activated. To add a name to the selected block, click on the
appropriate checkbox. If the box is already checked, the name will
be removed from the block.

In first-order logic, one object can have several names, but two
objects cannot share the same name. Hence Tarski’s World lets
you give a block more than one name, but once a name is used,
that name cannot be assigned to another block.
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3.2.6 Deleting blocks

To delete a block, drag the block off the edge of the grid and drop
it. Alternatively, select the appropriate block or blocks and hit the
Delete key.

3.2.7 Cutting, copying, and pasting blocks

If you want to copy some blocks from one file to another, use the
cut, copy, and paste functions.

If you select blocks and then choose Cut or Copy from the
Edit menu, the blocks are stored on the computer’s clipboard.
The difference between the two commands is that Cut deletes
the blocks from their present position, while Copy leaves them in
place. You can’t see the contents of the clipboard, but the blocks
will be there until you cut or copy something else to the clipboard.

Once some blocks are on the clipboard, they can be pasted into
a different (or the same) world. Just select the relvant tab and
choose Paste from the Edit menu. A copy of the blocks on the
clipboard will be inserted.

You can paste several copies if you want to, even into the same
world. Tarski’s World will attempt to paste the blocks in the same
configuration as they were cut, but will need to move them if there
are already blocks in any of those positions. Because two blocks
cannot have the same name, pasted blocks will have their names
removed.

3.2.8 Hiding labels

Whenever you name a block, Tarski’s World labels the block with
its name. Of course, in the real world we only wear name tags
at unpleasant social occasions. Like us, blocks in Tarski’s World
can have names without wearing labels. To hide the labels, simply
choose Hide Labels from the World menu. To redisplay the
labels, choose Show Labels from the World menu.

This command toggles the display of labels in all open worlds.

3.2.9 2-D view

Labels aren’t the only things that can hide. Sometimes a small
block can be obscured from view by another block in front of it.
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To get a bird’s eye view of the world, choose 2-D View from
the World menu. To get back to the usual perspective, choose
3-D View from the World menu. These commands can also be
accessed from the tool bar using the button which looks like a small
version of the checkerboard.

Blocks can be moved, selected, and changed from the 2-D view
in exactly the same way as the 3-D view. (You can even change
to the 2-D view in the middle of playing the game; sometimes you
will have to in order to pick an appropriate block, or to see what
Tarski’s World is referring to.)

3.2.10 Rotating Worlds

To rotate a world by 90 degrees in either direction, choose Rotate
World Clockwise or Rotate World Counterclockwise from
the World menu. Such a rotation counts as a change to the world
and will be saved when you save the world.

You can also rotate the world from the tool bar using the arrow
buttons.

3.3 The Sentence Panel

There are two ways to enter formulas into the sentence window,
from the sentence toolbar or from the keyboard. Most people find
it easier to use the toolbar than the keyboard.

3.3.1 Writing formulas

Tarski’s World makes writing first-order formulas quite painless.
As you may have noticed while playing with the sentence tool-
bar, when you enter a predicate, like Tet or BackOf, the inser-
tion point locates itself in the appropriate position for entering
“arguments”—variables (u, v, w, X, y, z) or individual constants (a,
b, c, d, e f).

What this means is that a sentence like BackOf(a,b) can be
entered into the sentence list with three mouse clicks in the toolbar:
first on the BackOf button, then on the a button, then on the b
button. To enter the same thing from the keyboard would require
11 keystrokes.
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In order to allow you to write more readable formulas, Tarski’s
World treats brackets (“[ ]7) and braces (“{ }”) as completely
equivalent to parentheses. Thus, for example, you could write
[LeftOf(a, b) A Large(a)] and Tarski’s World will read this sentence
as (LeftOf(a,b) A Large(a)). But you have to type brackets and
braces from the keyboard.

3.3.2 Commenting your sentences

You can add comments to your sentences in a way that will be
ignored by the program when it is checking to see if they are well
formed or true. You do this by prefacing each line of text you
want ignored by a semicolon (;). This will cause Tarski’s World
to ignore anything that follows on the same line. Tarski’s World
displays all of the characters in the comment in red to remind of
the their (in)significance.

3.3.3 Creating a list of sentences

To create a whole list of sentences, you first enter one sentence, and
then choose Add Sentence After from the Sentence menu. You
are given a new, numbered line, and can then enter a new sentence.
If you hit the Return key, this will not start a new sentence, but
will simply break your existing sentence into two lines. Use Add
Sentence After!

Instead of choosing Add Sentence After from the Sentence
menu, you can do this from the toolbar by clicking the Add After
button or you can do it directly from the keyboard in two ways.
You can type Shift-Return (that is, type Return while holding the
shift key down) or use the keyboard equivalent shown in the menu.

To insert a new sentence in your list before the current sentence,
choose Add Sentence Before from the Sentence menu, or using
the Add Before button on the toolbar.

3.3.4 Moving from sentence to sentence

You will often need to move from sentence to sentence within a
list of sentences. You can move the insertion point with the up
and down arrow keys (7, |) on the keyboard or by clicking on the
sentence of interest with the mouse. The left and right arrow keys
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Table 3.1: Keyboard equivalents for typing symbols.

Symbol Key Symbol Key
-~ S s
A & v |
— $ — %
v Q@ 3 /
C € \

(«, —) on the keyboard also move the insertion point, but only
within a single sentence.

If you hold down the Option key, the up arrow takes you to
the first sentence of the list, the down arrow takes you the last
sentence of the list, and the left and right arrows take you to the
beginning and the end of the current sentence.

3.3.5 Deleting sentences

To delete a whole sentence and renumber the sentences that re-
main, choose Delete Sentence from the Sentence menu. First
make sure the insertion point is somewhere in the sentence you
want to delete.

Note that you cannot highlight parts of two different sentences
and then delete them. If you want to delete a sentence boundary,
you must use the command Delete Sentence from the Sentence
menu.

3.3.6 Typing symbols from the keyboard

Sentences can be entered into the sentence window by typing them
on the physical keyboard. When typing predicates in the blocks
language, you must be sure to spell them correctly and to capitalize
the first letter (since otherwise they will be interpreted as names,
not predicates). You also have to insert your own punctuation:
parentheses after the predicate, and commas to separate multiple
“arguments” (as in Between(a,x,z)). To get the logical symbols
use the keyboard equivalents shown in Table 3.1.

Either the sentence window or the Keyboard window must be
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“active” before typing on the physical keyboard will have any ef-
fect. If you type and nothing shows up, that’s because the world
panel is currently the active panel. To activate the other panel,
just click in it somewhere.

You can change the size of the font used to display sentences
using the Text size submenu on the Sentence menu.

3.3.7 Cutting, copying, and pasting

If you want to change the order of the sentences in a list, or copy
a sentence from one file to another, use the cut, copy, and paste
functions.

If you highlight a string of symbols and then choose Cut or
Copy from the Edit menu, the string of symbols is stored on the
computer’s clipboard. The difference between the two commands
is that Cut deletes the highlighted symbols from their present po-
sition, while Copy leaves them in place. You can’t see the contents
of the clipboard, but the symbols will be there until you cut or copy
something else to the clipboard.

Once something is on the clipboard, it can be pasted anywhere
you want it. Just put the insertion point at the desired place and
choose Paste from the Edit menu. A copy of the string of symbols
on the clipboard will be inserted. You can paste several copies at
several different points, if you want to.

You can copy sentences out of Tarski’s World and paste them
into Fitch or Boole, and vice versa.

3.4 Verifying syntax and truth

As you will learn, only some strings of symbols are grammatically
correct, or well formed, as we say in logic. These expressions are
usually called well-formed formulas, or wffs. And only some of
these are appropriate for making genuine claims about the world.
These are called sentences. Sentences are wifs with no free vari-
ables. You will learn about these concepts in the text.

To see if what you have written in the sentence window is a sen-
tence, and if so, whether it is true in the world currently displayed,
click on the Verify button in the toolbar, or type Command-Return
(Control-Return on Windows). If you want to check a whole list
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of sentences, choose Verify All Sentences from the Sentence
menu. Alternatively, use the Verify All button on the tool bar.

When you verify a sentence, the results are displayed in the
margin to the left of the sentence number: “T” or “F” indicates
that the sentence is true or false in the world, “x” indicates that
the formula is not well-formed or not a sentence, while “+” indi-
cates that the formula is a sentence of first-order logic, but not
evaluable in the current world. If you are unsure why a sentence
is not evaluable, verifying the sentence again will result in a dialog
explaining the reason.

The evaluations are removed when the sentence or world is
changed.

3.5 Playing the game

When you stake out a claim about a world with a complex sentence,
you are committed not only to the truth of that sentence, but also
to claims about its component sentences. For example, if you are
committed to the truth of a conjunction A A B (read “A and B”)
then you are also committed both to the truth of A and to the truth
of B. Similarly, if you are committed to the truth of the negation
-A (read “not A”), then you are committed to the falsity of A.

This simple observation allows us to play a game that reduces
complex commitments to more basic commitments. The latter
claims are generally easier to evaluate. The rules of the game are
part of what you will learn in the body of this book. Here, we will
explain the kinds of moves you will make in playing the game.

To play the game, you need a guess about the truth value of
the current sentence in the current world. This guess is your initial
commitment. The game is of most value when this commitment is
wrong, even though you won’t be able to win in this case.

To start the game, click the Game button on the sentence tool
bar. Tarski’s World will begin by asking you to indicate your initial
commitment. At this point, how the game proceeds depends on
both the form of the sentence and your current commitment. A
summary of the rules can be found in Table 9.1 in Chapter 9 of
the textbook.
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3.5.1 Picking blocks and sentences

As you see from the game rules, at certain points you will be asked
to pick one sentence from a list of sentences. You do this by clicking
on the desired sentence and then clicking OK.

At other points in the game, you will be asked to pick a block
satisfying some formula. You do this by moving the cursor over
the desired block and selecting it. Then click OK. If necessary,
Tarski’s World assigns a name to the chosen block, for example nl,
and labels it.

3.5.2 Backing up and giving up

Tarski’s World never makes a mistake in playing the game. It will
win if it is possible for it to win, that is, if your initial commitment
was wrong. However, you may make a mistake, and so lose a game
you could have won. All it takes is some bad choices along the way.
Tarski’s World will take advantage of you. It will not tell you that
you made a bad move until it has won, when it will inform you
that you could have won. What this means is that there are two
ways for you to lose: if you were wrong in your initial assessment,
or if you make a faulty choice in the play of the game. To put this
more positively, if you win a game against the computer, then you
can be quite sure that your initial assessment of the sentence, as
well as all subsequent choices, were correct.

To make up for the edge the computer has, Tarski’s World
allows you to retract any choices you have made, no matter how far
into the game you’ve gone. So if you think your initial assessment
was correct but that you’ve made a bad choice along the way, you
can always retract some moves by clicking on the Back button.
If your initial assessment really was correct, you should, by using
this feature, eventually be able to win. If you can’t, your initial
commitment was wrong.

If, halfway through the play of the game, you realize that your
assessment was wrong and understand why, you can stop the game
by clicking the End button. This ends the game, but does not shut
down Tarski’s World.
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3.5.3 When to play the game

In general, you won’t want to play the game with every sentence.
The game is most illuminating when you have incorrectly assessed
a sentence’s truth value, but are not sure why your assessment
is wrong. When this happens, you should always play the game
without changing your commitment. Tarski’s World will win, but
in the course of winning, it will usually make clear to you exactly
why your assessment was wrong. That’s the real value of the game.

You might wonder what happens when you play the game with
a correct assessment. In this case, if you play your cards right, you
are guaranteed to win. But Tarski’s World does not simply give up.
At those points in the game when it needs to make choices, it will
make them more or less randomly, hoping that you will blunder
somewhere along the line. If you do, it will seize the opportunity
and win the game. But, as we have noted, you can always renege
by backing up.

3.6 Preferences

Some aspects of the behavior of Tarski’s World can be controlled
using the preferences dialog. This can be accessed by choosing the
Preferences... command from the application menu (Edit Menu
on Windows). The preferences dialog is shown in figure 3.2.

The first row of preferences are checkboxes which allow you to
switch on some options for opening and creating new worlds.

You can opt to create a random world instead of an empty one
when a new world is created by selecting the open with random
world checkbox. You can view an animation as the world is opened
or created by selecting the open with flythrough checkbox, and
you can opt to always open worlds in 2-D by selecting the final
checkbox.

You can control the speed of animations, or switch all anima-
tions off using the Animation panel. The speed of animations is
controlled by a slider. When the slider is set to the Fast end of the
scale, the animations will have fewer frames, resulting in a more
jerky animation which takes less time. The Smooth end of the
scale will result in smoother, but longer, animations. You might
like to play with this setting to get the effect that is just right for
your computer. If nothing seems right, then you can switch all
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Figure 3.2: Tarski’s World Preferences Dialog

animation off.

You can choose a different effect for how new blocks are created,
varying from dropping from the sky, materializing or growing in
place. We think that the effects are pretty nifty. You might like
to try them out.

The final world preference determines the size and shape of
the block that is created when the New Block button is pressed.
You have the option of being presented with a dialog box, always
creating the same kind of block, or allowing Tarski’s World to
choose a size and shape for you.

The final option concerns the display of text in the sentence
pane. You may opt to specify a default font size for the sentence
panel.
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Chapter 4

Using Fitch

Fitch is an application that makes it easy to construct formal proofs
in first-order logic. We begin with instructions on how to start and
stop Fitch, and explain the basic layout of the screen.

4.1 Getting started

The Fitch application is contained inside the folder called Fitch
Folder. Also in this folder is a folder called Fitch Exercise Files, in
which you will find the Fitch exercise files referred to in the book.

When Fitch is running, you will see (from top to bottom) the
ubiquitous narrow menu bar, a wider, gray “tool bar,” and a large,
mostly blank window, called the “proof window,” with a blue “goal
strip” at the bottom. Here are the basic facts to remember about
each of these.

4.1.1 The menus

Fitch has the following menus:

o File: This menu lets you start new proof files, open existing
proofs, save proofs, and print proofs.

o Edit: This is the customary edit menu allowing one to cut,
copy and paste items in proofs.

31
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o Proof: The items on this menu allow you to add steps to
proofs, to begin and end subproofs, to check the correctness
of proofs, and to display step numbers.

o Goal: The items on this menu allow your instructor to set
goals in problems and allow you to see whether any special
constraints apply to the goals.

o Window: This menu gives you access to various Fitch files
you have open, and allows you to change the font and ap-
pearance of your open windows.

4.1.2 The tool bar

The strip containing logical symbols and predicates located at the
top of the proof window is called the “tool bar.” It is like the
sentence tool bar in Tarski’s World, and is used for writing and
editing in the proof window. Moving your cursor over an item on
the tool bar turns it into a button. Clicking on the button enters
the symbol or predicate into the proof. The portion of the tool
bar containing predicates can be scrolled back and forth using the
double-arrow buttons on the tool bar. Try this so that you can
see what is available. There are too many predicate and constant
symbols to make them all visible at once.

On the far left of the tool bar are two buttons that are used
to switch back and forth between two tools. You will normally
use the top, pointer tool. The selection rectangle tool is used for
cutting and pasting multiple steps in a proof.

On the far right of the tool bar are three buttons that allow you
to check an individual step in your proof, verify the whole proof,
or see the constraints on the goals of the proof.

4.1.3 The proof window

The proof window is itself divided into two areas. The larger top
part or “pane” is where you construct proofs. When you add steps
or subproofs to proofs, for example, this is where they will show
up. When you add a step to a proof, the word Rule? appears on
the right. This is a popup menu that you click on to choose the
rule you want to use at the step.
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The bottom pane of the proof window is where the problem’s
goals appear, that is, the sentences to be proven. If the goal strip
is not visible, choose Show Goal Strip from the Goal menu. To
hide it, and give yourself more room in the proof pane, choose
Hide Goal Strip from the Goal menu.

At the extreme bottom of the proof window, under the goal
strip, is a Status Line that displays comments and error messages.
The status line is the bottom gray strip where you sometimes see
scroll bars. It is initially blank, but it is used to present a lot of
useful information, especially when proof steps don’t check out.
You can also check the step of the proof in focus by simply clicking
on the status line.

4.2 Creating and editing proofs

The body of a proof appears in the large pane in the middle of
the window, sandwiched between the tool bar and the goal strip.
In this section, we explain how to create, modify, and navigate
around a proof. Before doing this, we present a list of some of the
graphical elements you will encounter in the proof pane:

Proof line and Fitch Bar. Proofs and subproofs are de-
marcated by a vertical gray line. Attached to the line is a
horizontal bar called the Fitch bar. The Fitch bar separates
the assumptions of the proof from the steps that follow from
those assumptions.

[s Focus Slider. The focus slider appears just to the left of
the proof and points to the currently focused step. If there
are goals in the goal strip, the focus slider can also point at
one of the goals. There is only one focus slider in the window
at any time.

Step Bullet. This little square icon indicates the presence
of a step in the proof. You can either add a new sentence
at the step, if none is present, or you can edit an existing
sentence. If step numbers are displayed (Show Step Num-
bers from the Proof menu), the step bullet is replaced by
the step number.
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[P Goal Bullet. This “turnstile” icon precedes each of the goal
sentences in the goal strip (unless one is in focus, in which
case the turnstile is replaced by the focus slider).

E? Constant Box. The constant box appears at the top of
subproofs in which a new constant or constants have been
introduced. The constant box depicted here indicates that
a is a newly introduced constant. The downarrow to its left
indicates a menu where constants can be added or removed
from this box.

= Fule? Rule menu icon. This indicates a popup menu where you
can choose a rule to justify a step of the proof.

4.2.1 Step numbers

Normally, Fitch does not display step numbers, but simply indi-
cates the steps with bullets. Choosing Show Step Numbers from
the Proof menu will replace the bullets with numbers. When you
display step numbers, the support steps are indicated by number
next to the rule name, exactly as they are shown in the text.

4.2.2 The current focus

As you work on a proof, there is always one step that is “in focus.”
This step is indicated by a small triangle on the far left of the proof,
called the Focus Slider. The focused step is the step affected
when you perform any of the editing functions. It is also the step
that is checked if you click on the Check Step button or on the
status line at the very bottom of the proof window.

4.2.3 Moving the focus

There are three ways to change the focus from one step to another:
You can drag the focus slider up and down, you can click in the
focus slider area next to the step you want to focus on, or you
can use the arrow keys on the keyboard to move the focus up and
down.

Clicking on a step other than the currently focused step won’t
move the focus, unless you click in the focus slider area to the left.
This is because clicking on steps is the way we enter supports for
the currently focused step. (See page 37.)
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4.2.4 Adding new steps

To add a new step to a proof, choose Add Step After or Add
Step Before from the Proof menu. These commands will give
you a new proof step immediately after or before the step you were
focused on, unless you were focused on a premise, in which case
the new step will be the first step following the premises. To add
a step at the end of the proof, focus on the last step of the proof
and choose Add Step After. If you are working backwards in a
proof, you will often want to add a step immediately before the
step in focus, using Add Step Before. Steps can be inserted in
the middle of a proof in the obvious way, by first moving the focus
and then choosing the appropriate add step command.

New steps added within a subproof will appear in the same sub-
proof. Starting and ending subproofs require different commands.
These are described on page 39. Adding premises to a proof is
discussed on page 43. Normally, though, you will not be adding
premises to your proofs, since the exercise files contain the premises
already.

4.2.5 Entering sentences into steps

When you add a new step to a proof, the step icon (a small box)
will appear. At this point you can enter a sentence. To enter a
sentence, either use the tool bar or type directly from the keyboard.
To type the logical symbols from the keyboard, refer to the list of
keyboard equivalents found in Table 3.1 on page 23. These are the
same keyboard equivalents used in Tarski’s World and Boole.

In general, entering sentences is faster using the tool bar. How-
ever some sentences must be entered using the keyboard, since
the predicates, names, or sentence letters may not appear on the
tool bar. For example, you will have to type parts of the sentence
P — (QVR), since P, Q, and R don’t appear on the tool bar.

4.2.6 Deleting steps

To delete a step, focus on the step and choose Delete Step from
the Proof menu. If you delete the assumption step of a subproof
(the step just above the Fitch bar), the entire subproof containing
that step will be deleted. Be careful in deleting assumption steps,
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Figure 4.2: Using hierarchical menus to specify rules.

since you could lose a lot of work. If you simply want to change
the assumption, just edit the sentence.

You can either cut or delete a range of steps by using the se-
lection rectangle on the tool bar. Use the rectangle tool to select
the steps you want and then cut or delete them.

4.2.7 Specifying a step’s rule

When you add a new step, the word “Rule?” appears to the
right of the step. To specify a rule for the step, click down on the
word “Rule?” A popup menu will appear. This menu has three
submenus plus the rule of Reit.

The three submenus are attached to Intro, Elim, and Con.
Moving the cursor over these submenus will cause a second menu
to appear with a list of further options. To specify the rule of, say,
Negation Introduction, first move the cursor over the item Intro.
Then, when the second menu appears, move the cursor to the
item — (or “not”) and release the mouse button. This operation
is illustrated in Figure 4.2. Similarly, to specify the rule of Taut
Con, first move the cursor over the item Con and then choose
Taut from the second menu.

You can also specify a rule from the keyboard, by typing the
appropriate keystroke equivalent. A list of these appears in Ta-
ble 4.1. Note that in using these keyboard equivalents, you should
not hold down the shift key unless it is explicitly mentioned in the
table. For example, to specify the rule V Elim, you will actually
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Table 4.1: Keystroke equivalents for specifying rules.

Rule Equiv Rule Equiv

A Elim Opt(Alt)-& A Intro Shift-Opt(Alt)-&
V Elim Opt(Alt)-| V Intro Shift-Opt(Alt)-|

- Elim Opt(Alt)-~ = Intro Shift-Opt(Alt)-~
1 Elim Opt(Alt)- - 1 Intro Shift-Opt(Alt)- ~
— Elim Opt(Alt)-$ — Intro Shift-Opt(Alt)-$
< Elim Opt(Alt)-% « Intro Shift-Opt(Alt)-%

= Elim Opt(Alt)-= = Intro Shift-Opt(Alt)-=
v Elim Opt(Alt)-@ V Intro Shift-Opt(Alt)-Q
3 Elim Opt(Alt)-/ 3 Intro Shift-Opt(Alt)-/

Reit Opt(Alt)-R FO Con  Opt(Alt)-F
Taut Con  Opt(Alt)-T Ana Con  Opt(Alt)-A

type Option-2 (Macintosh) or Alt-2 (Windows); holding down the
shift key will change the rule to V Intro instead. In most cases, we
have listed the shifted (“uppercase”) characters because they are
easier to remember. For example, it is easier to remember that A
Elim is Option-& than to think of it as Option-7.

4.2.8 Changing a step’s rule

To change the rule of an existing step, you must first move the
focus to that step. Then specify the new rule using either the
popup menu or the keystroke equivalents.

4.2.9 Specifying a step’s supports

Most rules require that you cite other steps as justification or “sup-
port.” To specify the supports for a step, focus on that step and
click on the steps to be cited. The steps you click on will highlight.
If your support is a subproof, clicking anywhere in the subproof
will highlight the whole subproof. If you click on a step or subproof
that has already been cited, it will be uncited.
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To see a step’s supports, just focus on the step in question. The
supporting steps will then become highlighted. To change a step’s
supports, focus on the step and click on the steps you wish to add
or delete from the step’s supports.

If you are displaying step numbers in a proof, then the sup-
port steps are not indicated with highlighting, but rather by step
numbers appearing to the right of the rule name. Thus with step
numbers displayed, your proofs will look like the proofs in the text.

4.2.10 Checking steps and verifying proofs

To check whether a step is correct, focus on the step and either
press the Check Step button on the toolbar or click on the status
line at the bottom of the window. (On the Macintosh, you can also
check a step by hitting the Enter key on the numeric keypad.)

You can check all of the steps in your proof, plus the goals,
by clicking Verify Proof on the toolbar or by choosing Verify
Proof on the Proof menu.

After you check a step, one of four symbols will appear to the
left of the rule name.

v Check mark. A check mark means that the step is logically
correct.

x X. An X means that the step is logically incorrect.

E Asterisk. An asterisk means that the sentence at that step
is not syntactically well-formed.

? Question mark. A question mark will appear if a Con rule
is unable to determine the validity of your step.

If you don’t get a check mark for one of your steps, focus on that
step and look at the message in the status line. With luck, it will
provide you with some helpful information about why your step
did not check out.

4.2.11 Rule Defaults

Many of rules have defaults that can save you considerable time
when constructing a proof. For example, if you choose the rule



Usineg FrrcH / 39

— Elim, cite two sentences of the form P — Q and P, and then
check the step, Fitch will automatically fill in the step with the
sentence Q. To get Fitch to provide a default for a step, the sen-
tence must be blank, that is, there must not be any text already in
that step. If the sentence is blank when the step is checked, Fitch
will try to provide a default sentence for that step. The defaults
for the rules are described in detail in the textbook.

The Taut Con, FO Con, and Ana Con procedures do not
have defaults.

4.2.12 Starting and ending subproofs

A subproof is started by choosing New Subproof from the Proof
menu. When you start a new subproof, you can enter a sentence (or
boxed constant) in the first step. Once you are within a subproof,
any new steps you add will be part of that subproof. To add a
step after a subproof, you need to know how to end the subproof.
To end the subproof, focus on any step in the subproof and choose
End Subproof from the Proof menu. This will end the subproof
and give you a new step following that subproof.

If, when you end a subproof, the last step of the subproof is
empty, then that step will just be moved out of the subproof. This
means you can end two embedded subproofs by choosing End
Subproof twice. The first time, you will end the innermost sub-
proof and get a new step in the outer subproof. The second time,
the new step will be shifted out of that subproof as well.

4.2.13 Boxed constants in subproofs

When you start a subproof, a downward-pointing triangle appears
where the step bullet would normally appear. This triangle in-
dicates the presence of a popup menu. If you click down on the
triangle, the menu will appear. In this case, the menu presents
you with a list of all the names available in Fitch. Choosing one
of these names adds the name as a boxed constant—unless it is
already boxed, in which case it is removed from the box. Boxed
constants are used in the rules V Intro, and 3 Elim.
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4.2.14 Deleting subproofs

To delete a subproof, focus on the assumption step that begins the
subproof and choose Delete Step from the Proof menu. This
will delete the entire subproof, so make sure you really want to do
that. If you simply want to change the assumption step, edit the
sentence, don’t delete the step.

4.3 Goals

The goals for a problem are represented by sentences that appear
in the goal strip at the bottom of the proof window. These are the
sentences that are to be proven in your proof. If the goal strip is
not visible and you would like it to be, choose Show Goal Strip
from the Goal menu. If the goal strip is visible but you would like
more room for the proof, choose Hide Goal Strip from the Goal
menu.

When you are working on a problem and think that you have
satisfied one or more of the goals, choose Verify Proof from the
Proof menu. Either a check or an X will appear to the right of
each goal. If an X appears, focus on the goal by clicking on it, and
read the error message that will appear in the status bar.

4.4 Copying and pasting

Fitch allows you to cut, copy, and paste various parts of a proof.
Mastering these operations will make the construction of proofs
much easier.

When you cut or copy something from a proof, it is placed
on the “clipboard.” The clipboard is a part of the computer’s
memory that you can’t see, but which stores whatever you have
cut or copied so you can later paste it somewhere else in the proof.
The difference between cut and copy is that the former deletes the
item in question from its current place in the proof, while the latter
leaves the proof itself untouched, and stores a copy of the item on
the clipboard.

Once something is on the clipboard, you can paste copies of it
into the proof as many times as you want. It will remain on the
clipboard until something else is cut or copied, at which point the
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new item replaces what used to be on the clipboard.

4.4.1 Copying and pasting sentences

To cut or copy a sentence, or part of a sentence, you must first
be focused on the step that contains the sentence. Select the por-
tion you want by clicking down at one end and dragging to the
other, holding the mouse button down as you drag. Once it is se-
lected, choose Copy or Cut from the Edit menu. Both of these
commands place a copy of the selected text on the clipboard; the
second simultaneously deletes it from the step.

If you want to copy an entire sentence from a step, you simply
focus on the step and choose Copy from the Edit menu. There
is no need to select the sentence. This places a copy of the whole
sentence from that step on the clipboard, ready to paste elsewhere
in the proof (or in another proof). This shortcut is particularly
useful if you want to copy one of the premises when the authoring
mode is off, for in that case the premise will be locked and you will
not, be able to select it.

Once the sentence is on the clipboard, you can paste it into
another step by moving to that step and choosing Paste from
the Edit menu. The text will appear wherever text typed from
the keyboard would, so if you want to paste it into the middle of
some existing text, make sure the blinking insertion point is located
where you want the text to appear.

4.4.2 Copying and pasting goal sentences

You can copy a goal sentence by focusing on it and choosing Copy
from the Edit menu. This is an easy way to grab the desired
sentence and paste it into your proof.

4.4.3 Copying and pasting ranges of steps

Fitch allows you to cut or copy a range of steps and paste them
at another location in the same proof or in another proof. This
is especially useful if your proof requires several similar subproofs,
each containing a similar sequence of steps.

To cut or copy steps, you must first select them using the se-
lection rectangle tool on the far left of the tool bar. Its icon is a
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rectangle. When you choose on this button, you are ready to select
a sequence of steps.

To select a sequence of steps, click down at the center of the
first step in the sequence and drag straight down to the last step.
A rectangle will appear, showing which steps are selected. If the
rectangle doesn’t contain the steps you want, click somewhere else
in the proof and the rectangle will disappear. You can then try
selecting the steps again. Note, however, that Fitch will not allow
the selection rectangle to cut a subproof in half: you must either
select steps entirely from within a subproof, or else select the sub-
proof as a whole. When the rectangle contains exactly the steps
you want, choose Cut or Copy from the Edit menu. Both of
these commands place a copy of the steps on the clipboard; Cut
also deletes the selected steps from the proof.

Once a sequence of steps is on the clipboard, choosing Paste
will insert the steps at the point of focus. If you are currently
focused on an empty step, the pasted steps will replace the empty
step. If you are currently focused on a step that is not empty, the
pasted steps will be inserted after the focused step.

If you want to paste steps into your proof immediately following
a subproof, but not as part of the subproof, you will have to end
the subproof before pasting. This will give you an empty step
outside the subproof and Paste will replace this empty step with
the steps on the clipboard.

When you paste steps into a proof, Fitch will try to keep track
of the appropriate supports for those steps. Sometimes, though,
the supports for the pasted steps will no longer be “legal” in the
new location, for example if you paste a step into the proof at a
point earlier than one of its support steps. In such cases, Fitch will
remove the illegal support from the step’s list of supports.

Note that the selection tool also gives you a handy way to delete
a large number of steps. Rather than repeatedly choosing Delete
Step from the Proof menu, simply select all of the steps you wish
to delete, and choose Clear from the Edit menu. Simply hitting
the Delete key will also delete the selected range of steps.

When you are finished with the selection tool, don’t forget to go
to the tool bar and switch back to the normal, pointer tool. While
you have the selection tool, you will not be able to cite support
steps.
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4.5 Printing proofs

To print a proof, choose Print... from the File menu. When
you do this, you will be given the standard print dialog box. Once
you have chosen any printer options you want to use, click on the
Print button in the dialog box. In the printed proof Fitch adds
numbers to all of the steps and uses these numbers to indicate each
step’s supports so that the printed proofs look like the proofs in
the textbook.

4.6 Setting up exercises

Fitch has two modes of operation, user mode and author mode.
Students normally use the program in user mode, so exercise files
are always opened in user mode. This mode allows you to construct
proofs, but not to change the premises or goals of the proof, which
of course is not permitted in solving the exercises. (The Grade
Grinder always checks to make sure that no changes have been
made to the premises or goals of a proof.)

Author mode is used for creating new exercises, and so new
files are always opened in author mode. This mode allows you to
enter premises into the proof, add goals to the proof, and specify
any constraints that apply to the goals.

You can tell which mode you are in by looking at Author
Mode on the Edit menu. If there is a check in front of Author
Mode, Fitch is in author mode; otherwise, it is in user mode.
Choosing Author Mode will toggle between these two modes.

The current mode is saved with the file, so if you create a
new problem, you should turn off author mode before saving it.
Alternatively, you can use Save As Problem... from the File
menu. This will change the mode of the saved file to user mode.

4.6.1 Adding and deleting premises

To add a premise, you must be in Author Mode. Choose Add
Premise from the Proof menu. If you are currently focused on
a premise step, the new premise will appear immediately after the
focused step. If you are focused on a step in the body of the proof,
the new premise will appear at the end of the list of premises.
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To delete a premise, focus on its step and choose Delete Step
from the Proof menu.

4.6.2 Adding and deleting goals

To add a goal to a problem, choose New Goal from the Goal
menu and enter the goal sentence you want. As noted above, this
can only be done in Author Mode. To delete a goal from a problem,
click on the goal in the goal strip and choose Delete Goal from
the Goal menu.

If you want to modify the constraints on a goal, choose Edit
Goal Constraints from the Goal menu. When you initially add
a goal, Fitch assumes that you want the goal to be proven using
just the introduction and elimination rules of F. If you want to
allow the use of the Con procedures, or if you want to disallow the
use of any standard rules, you will have to modify the constraints
associated with the goal. Constraints are associated with individ-
ual goals, so a problem can have different constraints for different
goals.

4.6.3 Saving new problems

To save a newly created file as an exercise to be solved, choose
Save As Problem... from the File menu. This saves the file,
but also turns on User Mode in the file, so that users will not
accidentally change the premises or goals of the exercise.
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Chapter 5

Using Boole

Boole is an application that makes it easy to construct truth tables.
We begin with instructions on how to start and stop Boole, and
explain the basic layout of the screen.

5.1 Getting started

The Boole application is contained inside the folder called Boole
Folder. When Boole is running, you will see (from top to bottom)
the menu bar, a wider, gray “tool bar,” a narrow pink “assess-
ment pane,” and finally a large, mostly blank area for constructing
truth tables, called the “table pane.” Here are the basic facts to
remember about each of these.

5.1.1 The menus

Boole has the following menus:

o File: This menu lets you start new truth tables, open exist-
ing tables, save tables, and print tables.

o Edit: This is the customary edit menu allowing you to cut,
copy and paste items in truth tables.

o Table: This menu contains commands for adding new columns,
for verifying your table, and for generating reference columns
automatically.
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o Window: This menu gives you access to various Boole files
you have open.

5.1.2 The tool bar

The strip containing logical symbols and predicates located at the
top of the proof window is called the “tool bar.” It is like the sen-
tence tool bar in Tarski’s World, and very similar to the tool bar
in Fitch. Moving your cursor over an item on the tool bar turns it
into a button. Clicking on the button enters the symbol or predi-
cate, if the insertion point is located in one of the sentence fields
at the top of your table. The portion of the tool bar containing
predicates can be scrolled back and forth using the double-arrow
buttons on the tool bar.

On the far right of the tool bar are six buttons for use in con-
structing and checking tables. The function of these buttons is as
follows:

o Delete Column: This button deletes the sentence column
that contains the insertion point. It will delete the sen-
tence at the top of the column and all associated truth value
columns under that sentence. You will have a chance to can-
cel the deletion after you click the button.

o Build Reference Columns: This button can be used after
you have entered one or more target sentences on the right
side of your table. If you choose this button, Boole will auto-
matically create all of the reference columns needed for your
table. You should use this feature only if the exercise says
that you can, since otherwise the Grade Grinder will com-
plain that you did not create your own reference columns.
Learning how to create reference columns is part of what
you must master when learning to build truth tables.

o Fill Reference Columns: This button fills in the truth val-
ues under the reference columns for you. Like the preceding
button, you should only use this if the exercise says that you
can, since filling in the reference columns is another crucial
skill to master in building truth tables.

o Verify Row: Clicking this button will verify the correctness
and completeness of a single row of your truth table.
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o Verify Table: Clicking this button will verify the correct-
ness and completeness of your entire table.

o Verify Assessment: This button verifies the correctness of
your table (as does Verify Table), but also checks to see
whether your assessment is correct.

5.1.3 The assessment pane

The assessment pane is similar to the goal pane in Fitch. This is
where you look to see whether your truth table is correctly con-
structed. It also contains a button that allows you to assess the
target sentence or sentences in your table. When you click the
Assessment button, you are presented with a list of possible as-
sessments. For example, if you are asked to determine whether a
sentence is a tautology, you can specify whether or not it is. If
you are asked to determine whether a sentence is a tautological
consequence of other sentences, you can specify this here as well.

5.1.4 The table pane

The large, mostly white area is where you construct truth tables.
A thin horizontal line divides the headings of the columns from
the truth value columns. A thick vertical line divides the refer-
ence columns from the body of the table. When the insertion
point is in the heading area, you can enter target sentences on the
right or reference sentences on the left. New sentence columns are
added using the commands Add Column After or Add Col-
umn Before from the Table menu. Once sentences are entered,
truth values can be entered in the appropriate places under those
sentences.

5.1.5 Adjusting the table pane

The table pane is divided into two parts: the reference columns on
the left and the target columns on the right. These are separated by
a vertical divider. Often when you open or construct a table, you
will not be able to see all of the columns on one or the other side.
You can adjust the overall size of your window in the usual way,
and you can also change the position of the divider by grabbing it
and dragging to the left or right.
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5.2 Writing and editing tables

There are three steps in creating a truth table: specifying the
target sentence (or sentences), building the reference columns, and
filling in the truth values. Once a table is complete, it can be used
to assess the logical properties of the target sentences.

5.2.1 Entering target sentences

To enter a target sentence, the insertion point must be blinking
in the upper right section of the table. If it is not, click in this
area to place the insertion point where you want it. Then enter
the desired sentence using the tool bar or keyboard. To type the
logical symbols from the keyboard, refer to the table of keyboard
equivalents on page 23. Notice that as you enter the sentence, the
sentence number above the sentence changes color. If the sentence
is ill-formed, the number is red; when it is well-formed, it turns
green.

If you are constructing a joint truth table for two or more sen-
tences, you will need to choose Add Column After or Add Col-
umn Before from the Table menu to add a new target sentence
to your table.

Another way to enter sentences is by copying them from Tarski’s
World or Fitch and pasting them into the appropriate place in
Boole.

5.2.2 Creating reference columns

There are two ways to create reference columns: you can do it
by hand or you can have Boole do the work for you. You should
always do the work yourself unless the exercise or your instructor
gives you permission to let Boole build the reference columns for
you.

To enter a reference sentence, click at the top of the first col-
umn to the left of the thick dividing line. Then enter the desired
atomic sentence. (Boole will allow you to enter any formula in a
reference column. The number above the sentence will be red if
the sentence is ill formed and blue if it is not atomic.) To add ad-
ditional reference sentences, choose Add Column After or Add
Column Before from the Table menu, and enter the sentence.
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If you want Boole to build the reference columns for you, click
on the button Build Ref Cols on the tool bar. This will generate
the necessary reference columns for the target sentences currently
appearing on the right. If Boole generates the reference columns,
they will be numbered =1=, =2=, .. .; if you build them, they will
be numbered (1), (2), ....

5.2.3 Filling in truth values

To fill in truth values in your table, click in the desired column
and type T or F. (You can also type “1” for T and either “0” or
“2” for F, if you find this more convenient.) After the letter is
entered, the insertion point will move down one row in the same
column. If you are working in a column on the right side of the
table, Boole will highlight the values elsewhere in the table that
the current value depends on. In other words, Boole implements
the “two finger” method described in the textbook.

Boole will also fill in truth values in the reference columns of
a table automatically, should you so desire. Only do this if the
exercise or your instructor says that you can. (The Grade Grinder
will complain if you do this without permission.) To fill them in
automatically, click Fill Ref Cols on the tool bar.

In its default mode, Boole will fill in values column by column.
That is, when you type a T or F, the insertion point will move
down one row so that you can fill in the next value in the column.
If you prefer filling in your table row by row, choose By Row in
the Edit menu. In Row mode, Boole will move the insertion point
to the next column after you type a truth value.

5.3 Specifying your assessment

Typically you will be asked to use truth tables to determine whether
a sentence is a tautology, whether two sentences are tautologically
equivalent, or whether a sentence is a tautological consequence of
others. Thus after you have constructed your truth table, you
will need to specify the relevant assessment of the sentence or sen-
tences in your table. To do this, click on the Assessment button
in Boole’s assessment pane. This will open a window allowing you
to specify your assessment.
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5.4 Verifying your table

There are three commands available for verifying portions of your
table: Verify Row, Verify Table, and Verify Assessment.
These are available both from the Table menu and on the tool
bar.

o Verify Row will verify the correctness and completeness
of a single row of your truth table. It checks the row that
contains the insertion point. If the row has all the necessary
reference columns and all the values in the row are filled in,
a + will appear next to Complete? in the assessment pane.
If the values filled in under the target sentence are correct, a
+ will appear next to Correct? in the assessment pane.

o Verify Table will verify the correctness and completeness
of your entire table. It checks whether you have all the nec-
essary reference columns, whether these contain all the re-
quired truth combinations, and finally, whether the values
specified under the target sentence are correct. If the table
has been completely filled out and the values are all correct,
check marks will appear next to Correct? and Complete? in
the assessment pane.

o Verify Assessment verifies the correctness of your table
(as does Verify Table), but also checks to see whether your
assessment is correct. Before it can do this, you must specify
an assessment, as described above.

5.5 Saving or printing your table

To save your table, choose Save or Save As... from the File
menu. If you are submitting a table to the Grade Grinder, you
should name it Table n.m, where n.m is the number of the exercise.

To print a table, choose Print from the File menu. When you
do this, you will be given the standard print dialog box. Once
you have chosen any printer options you want to use, click on the
Print button in the dialog box.
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cutting, 42
deleting, 40
deleting assumption step, 36
ending, 32, 39
starting, 32, 39
support
Fitch
specifying, 37-38

table pane

Boole, 49
tool bar

Boole, 48, 50

Fitch, 32, 35, 36, 42
TW Exercise Files

Tarski, 16
user data
Submit, 10
user mode
Fitch, 43
Verify
Boole
assessment, 49, 52
row, 48, 52
table, 49, 52
Fitch
proof, 38, 40
Tarski

syntax and truth, 24
vertical divider
Boole, 49
View
Tarski
2-D, 20
3-D, 21

Window menu
Fitch, 32
world panel
Tarski, 15
writing wifs
Boole
using keyboard, 50
using tool bar, 50
Fitch
using keyboard, 35
using tool bar, 35
Tarski, 21-22
WWW, 2



